Linux: Ubuntu 12.04

Note that newer versions of Dakota require newer Boost, CMake, and C++11 compilers so the below notes are out of date. This page is retained for reference.

Dakota 6.7

Guidance for building Dakota 6.7 on Ubuntu 12.04 has not been established.

Dakota 6.6

On Ubuntu, we satisfied Dakota's dependencies with the following.  Except as noted these are from the standard package repositories and installed with apt-get  install.

  • GNU compilers: stock packages gcc, g++, gfortran
  • CMake 2.8.9:compiled from source tarball
  • Boost 1.49: compiled from source tarball
  • Linear Algebra: stock packages libblas-dev liblapackdev; symlink libblas.so -> libblas.so.3 and similar for LAPACK library if needed.
  • OpenMPI: stock packages libopennmpi-dev openmpi-bin openmpi-doc
  • X Windows: stock packages xorg-dev libmotif-dev
  • Python (optional): Python development dependencies (if using direct Python interface): python-dev, and python-numpy if you'd like a NumPy interface.